Thursday, February 21, 2013

vCenter Server Heart Beat 6.5 with vCenter 5.0 U2 Installation verification testing results auto fail over issues.

vCenter Server heart beat 6.5 installation verification testing.

Not going to discuss on installation procedure, Refer installation document for pre requites and procedure, here i am going to detail only about the testing and verification that was done for vCSHB with VC 5.0 U2, in my lab.
vCenter server heart beat provides uses 4 terms for switch over and failover process as follows.

Managed switchover - Manually making the passive server to active and vice versa, with in the summary tab.
Automatic switchover - Automatically triggered when there is a failure in protected services detected.
Managed Failover -  If the passive server detect that the active server has failed, can send alerts to administrators, there administrator has to perform a manual failover.
Automatic Failover - Automatic failover same as automatic switchover, triggers when passive detects that active is not reachable.

1. Testing Managed Switchover\failover:

Usually performed when there is a maintenance or reboot required for the active nodes.

Connect vCenter server heart beat via Manage Server ( Considering that the groups are added already).
Click on connection under server tab in summary, you will see node, select the passive node and click on make active.
Successfull completion of switch over indicates the managed switchover completion.

2. Automatic switchover\failover:

Here come's the issue.

Logged on to the active server and did a shutdown of the server and failover didn't happen, was surprised and investigate further, later got a update from vmware support saying that its expected and only in case of power failure or a server crash the auto fail over or switchover will happen.

So incase of server shutdown, there is no auto failover.

then powered off the VM and clicked on edit setting, under option tab, clicked on vmware tools and changed the stop option from shutdown to power off.

then tested power off(that is unplug power cord), auto failover was successful.

Note: as per the installation document, it is mentioned that VMware recommends against
attempting to test failover on a properly operating Pair by methods such as unplugging a power cord. At the
moment power is lost, any data not written to the passive server is lost. VMware recommends that all actions intended to verify operation of the passive server be performed as a switchover rather than a failover.

Let me know your test out come or issue to discuss more.










No comments:

Post a Comment